Se encuentra usted aquí

apache

Mod Security y Webpay

Imagen de Nicolás Moncada Henríquez

Para operar con Webpay, necesitamos instalar una aplicación en nuestros servidores llamado KCC. Esta instalación puede llegar a ser no muy agradable para muchos, ya que esto puede tomar horas, días y hasta semanas para que quede funcionando al 100%. ¿El motivo? pueden ser varios: configuración de apache, php, permisos, llaves, etc. Pero uno de los más complejos es la compatibilidad con uno de los módulos de apache, el famoso mod_security. Ya con el hecho de concluir de que "es el responsable de hacer que siempre falle la transacción, haciéndonos caer en la famosa página de fracaso" es un gran logro, más aún cuando usas un hosting que por defecto lo tiene activado y uno no tiene idea de ello. Por lo tanto, ya sabiendo esto, una posible solución es simplemente desactivando el módulo, pero si quieres tener tu sitio protegido ante ataques entonces tendrás que dar con la regla indicada del mod_security para hacer funcionar Webpay y eso es lo que intentaremos hacer aquí.

Suscribirse a RSS - apache